On May 28, 2025, from approximately 09:45 UTC to 14:45 UTC, GitHub Actions experienced delayed job starts for workflows in public repos using Ubuntu-24 standard hosted runners. This was caused by a misconfiguration in backend caching behavior after a failover, which led to duplicate job assignments and reduced available capacity. Approximately 19.7% of Ubuntu-24 hosted runner jobs on public repos were delayed. Other hosted runners, self-hosted runners, and private repo workflows were unaffected.
By 12:45 UTC, we mitigated the issue by redeploying backend components to reset state and scaling up available resources to more quickly work through the backlog of queued jobs. We are working to improve our deployment and failover resiliency and validation to reduce the likelihood of similar issues in the future.
Posted May 28, 2025 - 14:43 UTC
Update
We are continuing to monitor the affected Actions runners to ensure a smooth recovery.
Posted May 28, 2025 - 14:35 UTC
Update
We are observing indications of recovery with the affected Actions runners.
The team will continue monitoring systems to ensure a return to normal service.
Posted May 28, 2025 - 13:42 UTC
Update
We're continuing to investigate delays in Actions runners for hosted Ubuntu 24.
We will provide further updates as more information becomes available.
Posted May 28, 2025 - 12:41 UTC
Update
Actions is experiencing degraded performance. We are continuing to investigate.
Posted May 28, 2025 - 11:49 UTC
Update
Actions is experiencing high wait times for obtaining standard hosted runners for ubuntu 24. Other hosted labels and self-hosted runners are not impacted.